Первичная настройка коммутатора Eltex

Общие моменты настройки.

Настройка коммутаторов марки Eltex для работы в сети какого-либо провайдера в целом и "ЛинкИнтел" в частности не представляет сложности. Рассмотрим общие моменты подготовки устройства к работе.
Подключаемся к коммутатору консолью, выставив Baud rate на 115200.
Welcome...
Говорим коммутатору enable, разрешая себе действия рутового юзера, а после conf, чтобы попасть в режим конфигурирования.
Настраиваем интерфейс управления.
interface vlan 1
Задаем ему IP-адрес и маску подсети.
ip address 172.16.201.18 255.255.128.0
Выходим из интерфейса - exit.

Теперь создадим VLAN-ы на коммутаторе.
Также в режиме конфигурирования conf заходим в базу вланов командой vlan database.
Допустим, нужен 206 и 231 VLAN.
vlan 206 name 206
vlan 231 name 206

Сохраняем конфигурацию - wr.

Настраиваем аплинки на коммутаторе.
Указываем Элтеху диапазон транковых (аплинк) портов, на которых будут тегированные вланы.
console(config)#int range GigabitEthernet 0/25-28
Говорим, что эти порты будут в транке.
switchport mode trunk
Добавляем вланы.
switchport trunk allowed vlan add 206,231
Сохраняемся - wr.

По тому же принципу настраиваем пользовательские порты. Они будут с 1 по 24.
console(config)#int range GigabitEthernet 0/1-24
В режиме "access"
switchport mode access
switchport access vlan 206
В данном случае мы добавили порты 1-24 в 206 влан, но в случае необходимости можно добавить некоторые/все порты и в другой.
Сейвимся wr.

Как ни странно, настройка практически завершена. Настраиваем мультикаст.
console(config)# bridge multicast filtering

console(config)# vlan database

console(config-vlan)# vlan 601
console(config-vlan)# exit

console(config)# interface range gi1/0/1-24

console(config-if)# switchport mode access


console(config-if)# switchport access multicast-tv vlan 601

console(config-if)# bridge multicast unregistered filtering

console(config-if)#exit

console(config)#int range GigabitEthernet 1/0/25-28

console(config-if)# switchport mode trunk

console(config-if)# switchport trunk allowed vlan add 601

console(config-if)#exit


console(config)# ip igmp snooping

console(config)# ip igmp snooping vlan 601
console(config)#ip igmp snooping vlan 206


Теперь проверим настройки на пользовательском порту.
console#show run interfaces gi1/0/2
interface gigabitethernet 1/0/2
 switchport access vlan 206
 bridge multicast unregistered filtering
 switchport access multicast-tv vlan 601

exit
wr


Подробнее о multicast-tv VLAN

На секунду отвлечемся от скучных строчек кода и разберемся, зачем нужна данная функция. Служит она очень важной цели - доставлять многоадресный трафик из одного отдельно взятого влана клиентам в этот влан не входящим. В случае, например, с IPTV в сети провайдера Multicast-TV VLAN существенно снизит нагрузку на сетку, т.к. мультикаст не будет дублироваться во все VLAN-ы.
Принцип работы тут такой. Клиентские порты должны работать в режиме access/customer и могут входить в любой влан за исключением самого multicast-tv VLAN. Юзеры могут только получать трафик из multicast-tv VLAN, но вещать в него не могут. Также на коммутаторе должен быть поднят интерфейс, играющий роль источника данного трафика и входящий в этот самый multicast-tv VLAN. В целом всё. Рассмотрим как это выглядит в живую в CLI свича.
Для начала включим фильтрацию многоадресного трафика.
console(config)# bridge multicast filtering

Создадим нужные вланы - управляющий (1001), мультикастовый (101) и клиентские (202-254).
console(config)# vlan database
console(config-vlan)# vlan 202-254,101,1001
console(config-vlan)# exit

Отлично, теперь настраиваем порты пользователей. В нашем примере будет использоваться Eltex линейки 2124 с гигабитными портами, поэтому интерфейсы будут GigabitEthernet (gi), в случае с более младшими моделями типа 1124 порты клиентов FastEthernet (fa):
console(config)# interface range gi1/0/1-24
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 202
console(config-if)# switchport access multicast-tv vlan 101
console(config-if)# bridge multicast unregistered filtering
console(config-if)#exit

Теперь перейдем к транку, т.е. настроим интерфейс Uplink. Тут нам надо разрешить мультикастовый трафик, клиентский и управление. Поехали.
console(config)# interface gi1/0/1
console(config-if)# switchport mode trunk
console(config-if)# switchport trunk allowed vlan add 202-254,101,1001
console(config-if)#exit

Теперь настроим ip IMP snooping в общем виде и в требуемых клиентских вланах:
Настроить igmpsnooping глобально и на интерфейсах, добавить привязку групп
console(config)# ip igmp snooping
console(config)# ip igmp snooping vlan 202
console(config)# ip igmp snooping vlan 203
console(config)# ip igmp snooping vlan 204
console(config)# ip igmp snooping vlan 205
…
console(config)# ip igmp snooping vlan 254

Во вланах, где не требуется вещание многоадресного трафика просто не включаем IGMP.
Ну, остается настроить управление свичом и дело сделано:
console(config)# interface vlan 1001
console(config-if)# ip address 172.16.101.221 255.255.255.0
console(config-if)# exit

Готово!

В общем и целом, это все. Осталось настроить работу loop detect и port-security, но об этом в следующий раз.скачать dle 12.0

Комментариев 5

  1. Офлайн
    Jack Frost 25 сентября 2016 18:18
    UPD. В статье указана настройка мультикаста, применительно для коммутатора доступа. Чтобы просто прокинуть VLAN дальше, делаем следующее.
    Создаем мультикаст влан, а-ля:
    conf
    vlan database
    vlan 601 name 601
    exit
    interface range gi1/0/25-28
    switchport mode trunk
    switchport trunk allowed vlan add 601


    Теперь пилим мультикаст бридж
    bridge multicast filtering
    И включаем IGMP в нужных вланах
    ip igmp snooping
    ip igmp snooping vlan 235
    ip igmp snooping vlan 601
  2. Офлайн
    Jack Frost 15 апреля 2017 15:05
    Важное замечание по настройке мультикаста.
    После настройки IGMP мультикаст может политься на коммутатор не сразу. На практике я наблюдал, что на аплинке вышестоящего коммутатора (аггрегация, DGS-3120-24SC) ТВ-приставка не появилась в мультикаст-влане и лился только юникаст. После переключения канала она затребовала подписку на мультикаст-группы, сразу подскочил трафик за портом и MAC-адрес приставки отобразился в искомом мультикаст-влане.
  3. Офлайн
    Гоша 12 октября 2017 19:10
    Админ, а для этих коммутаторов можешь написать настройки?
  4. Офлайн
    Jack Frost 12 августа 2019 13:06
    Настройка SNMP на модели MES2428 и в целом по данной линейке.
    Пример:
    snmp user SimpleUser
    snmp group SimpleGroup user SimpleUser security-model v2c
    snmp access SimpleGroup v2c read iso write iso notify iso
    snmp community index 1 name public seс SimpleUser
    snmp view iso 1 included

    Был добавлен обязательный т.н. "пользователь" и "группа пользователей" с "моделью безопасности". Чего отродясь на v2c не было.
Информация
Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.
  • Яндекс.Метрика